Help, mon AKS est obsolète !

Que se passe t-il lorsque votre cluster AKS n’est plus dans une version supportée par Microsoft ? Rassurez vous, tout espoir n’est pas perdu 🙂

grand plan sablier sable noir 127657 18481 - Help, mon AKS est obsolète !

Si vous êtes dans cette situation, normalement vous avez reçu un mail d’Azure Advisor vous informant que votre cluster n’est plus dans une version supportée. Vous avez alors 30 jours pour pouvoir faire l’upgrade. Vous retrouverez alors le support de Microsoft sur votre cluster AKS et fin de l’histoire 🙂

Pour le mode opératoire, voir cet article !

Le support Microsoft

Ne pas avoir de support signifie que si vous rencontrez un problème vous ne pourrez demander un accompagnement technique à Microsoft.

Vous ne pourrez pas non plus provisionner un nouveau nodepool sur votre cluster. Par contre l’autoscaler de cluster “devrait” fonctionner (le devrait vient de la doc officielle 🙂 )

Par ailleurs, si un cluster ne bénéficie plus du support depuis plus de trois versions mineures et présente des risques de sécurité, sans action de votre part, Azure se réserve le droit d’effectuer automatiquement la mise à jour à votre place.

Les versions K8S

Les versions mineures supportés par AKS sont au nombre de 3. La dernière version mineure GA publiée dans AKS et les deux versions mineures précédentes. Chaque version mineure prise en charge gère également deux correctifs stables au maximum.

Pour connaitre les versions supportées dans une région exécutez cette commande :

az aks get-versions --location eastus --output table

Le process de mise à jour

Lors d’une mise à jour du cluster, les versions mineures ne peuvent être ignorées. Par exemple, les mises à niveau 1.18.x, 1.19.x> et 1.19.x -> 1.20.x sont autorisées, mais pas 1.18.x -> 1.20.x.

Dans notre problématique, si ma version n n’est plus supportée, mais que la n+1 non plus, comment faire ?

Et bien rassurez vous il est possible de skiper une version lors de l’upgrade uniquement si cette version n’est plus supportée.

Par exemple, la mise à niveau d’une version 1.16.x non supportée vers une version 1.18.x peut être effectuée.

Dans tout les cas :

  • Votre cluster ne sera pas supprimé par Microsoft si la version est obsolète ! Par contre en cas de pépin vous ne pourrez pas compter sur le support technique.
  • En revanche, vous ne pourrez plus créer de cluster dans cette même version pour tester en amont votre upgrade …

 

La seule solution pour valider votre montée de version sera de déployer un nouveau cluster dans la version cible, y déployer vos apps et vérifier que tout fonctionne comme avant 🙂 Vous pourrez alors faire la montée de version de votre cluster initial.

Le mieux étant de ne pas laisser son cluster AKS rester dans une vieille version qui deviendra rapidement obsolète 🙂

A bientôt !

 

Thomas

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.